Why is the database restore not working in PCoIP Management Console 2.2.0?
Problem
The following errors related to PCoIP Management Console 2.2.0 database restore process have been reported:
- Importing db backup from version 2.1.0 into version 2.2.0 fails
- Cannot restore db backup into version 2.2.0.
- After a version 2.1 database restores to a new version 2.2 instance, nothing appears.
- After restoring, the PCoIP Management Console login page shows "waiting for server to start"
Cause
HP Anyware has tracked this issue to the hosts file located in the /etc directory. When the Network Configuration tool does not contain the correct information and writes to the hosts file, it corrupts the hosts file. The hosts file is the precursor to DNS. The hosts file is always checked before DNS and can override the DNS.
If you are setting up a DNS "A" record and a DNS "PTR" record for the MC then there is no need to modify the hosts file. The hosts file will get modified when you run DNS Configuration from the Network Config Tool mentioned below.
Resolution
1. Run the Network Configuration tool as per instructions in the PCoIP Management Console 2 Administrators' Guide. Type the following command:
sudo system-config-network
2. Under DNS Configuration, when entering the console's host name, ensure you enter the FQDN (Fully Qualified Domain Name) of the PCoIP Management Console. For example:
- If the MC hostname is: mymc220
- And the Domain is: something.local
- Then enter: mymc220.something.local
The hosts file, when viewed at /etc, should look like the following:
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 mymc220
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6 mymc220
3. After modifying the network configuration, save and quit. From the Linux prompt, restart the MC with the following command:
sudo init 6
4. For the above example, when checking DNS records both the A record and the PTR record were updated with the new name mymc220.something.local.
5. After ensuring the hosts file is correct and restarting the VM restore the database.
Note: HP Anyware is also seeing an issue with browser caching. In some cases, you may have to clear your browser's cache.
If you do not modify the DNS Configuration with the Network Configuration tool, the hosts file is shown as the following:
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6