Error: Broker failed to allocate the resource
Problem
When trying to connect to a PCoIP Agent that is brokered, the client returns the error "Broker failed to allocate the resource".
Cause
Broker failed to allocate the resource is a timeout error when broker fails to connect. The Broker is not able to reach the agent. Reasons for the error include:
- Unknown/expired JSESSIONID
- One or more required ports are blocked; TCP 443, 60443, 4172 and UDP 4172.
- The trusted storage on Agent become corrupted. "This version of trusted storage is not supported."
- Other
Resolution
1. Unknown/expired JSESSIONID
Review the broker logs under var/log.anyware-connector for the "Session-Log-ID found:" message that occurs before the (6606) error.
Load Balancer Issue:
- Ensure the load balancer determines CM and client connect based on jsessionid.
- If the load balancer round robins IPs based on time, a user that is mid-session establishment during the switch would be impacted by this. You could lengthen the round robin time, or remove it entirely.
- See How to configure a Load Balancer for the HP Anyware Connector.
2. One or more required ports are blocked; TCP 443, 60443, 4172 and UDP 4172.
The following Ports are required for the HP Anyware. Make sure these ports are not blocked.
HP Anyware PCoIP Agents | Port | Port Number | Direction | Description |
---|---|---|---|---|
HP Anyware all PCoIP Agent versions (Standard & Graphics) | TCP | 443 | In | Client Authentication |
TCP | 4172 | In | PCoIP Session Establishment | |
UDP | 4172 | In and Out | PCoIP Session Data | |
TCP | 60443 | In | Connection Broker Communication | |
TCP | 443 | Out | Cloud Licensing |
3. The trusted storage on Agent become corrupted. "This version of trusted storage is not supported."
Review the PCoIP Agent logs on the host for entries similar to:
AGENT :Failed to start the Agent: Failed to add FNE trial license source: [1,7E3,4,0[70000027,0,5002E]] This version of trusted storage is not supported.
It means the local trusted storage has become corrupted.
- Delete the contents of C:\ProgramData\Teradici\PCoIPAgent\licensing\5 in Windows, or /var/lib/pcoip-agent/licensing/5 (requires root permissions) in Linux.
- Restart the appropriate agent service (PCoIP Graphics Agent or PCoIP Standard Agent on Windows, or pcoip-agent on Linux)
- If using HP Anyware Cloud Licensing (not using a local license server), re-register the host.
4. Other Reasons
- Please ensure that you are using the latest version of Client and Agent.
- If possible, try to establish a direct connection without using a broker, this will help us to find out if broker is the reason for the issue.
- If you still see the issue, open a support ticket from our support site, https://help.teradici.com/s/contactsupport